Google Local Service Ads - Data Processing Delays

Incident Report for AgencyAnalytics

Resolved

Google has resolved the issue. Google Local Services Ads is now operating normally.
Posted 2 months ago. Jun 11, 2025 - 18:46 EDT

Identified

Google Local Service Ads is currently experiencing an issue where the service is returning the error:
The server encountered a temporary error and could not complete your request.

Google is working to fix the issue. We will keep you updated.
Posted 2 months ago. Jun 11, 2025 - 13:36 EDT
This incident affected: Data Components (Google Local Service Ads).