Application slowdown

Incident Report for AgencyAnalytics

Resolved

The issue has been resolved. Everything is operating normally.
Posted Apr 25, 2025 - 10:45 EDT

Update

The application is running normally again, however we're still investigating the root cause of the issue.
Posted Apr 25, 2025 - 10:13 EDT

Identified

We've identified the area causing the application slowdown and are working on a fix. We'll provide an update shortly.
Posted Apr 25, 2025 - 09:29 EDT

Investigating

We're investigating reports of slowdowns across the application. We'll provide an update shortly.
Posted Apr 25, 2025 - 08:59 EDT
This incident affected: API, Dashboard, Website, and Task Management.