Degraded performance of Google Local rankings

Incident Report for AgencyAnalytics

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 12:15 EDT

Update

All keywords affected by our ranking provider's recent outage have now successfully refreshed.
Posted Sep 18, 2026 - 12:14 EDT

Investigating

We're currently investigating an issue affecting Google Local ranking data.

Our team is actively working to identify the cause, and we'll provide updates as we learn more.
Posted Sep 15, 2026 - 16:26 EDT
This incident affected: Data and Integrations (Rankings).