Issues saving and exporting reports
Incident Report for AgencyAnalytics
Resolved
This incident has been resolved.
Posted Aug 24, 2023 - 13:02 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 24, 2023 - 12:45 EDT
Investigating
We are currently investigating this issue.
Posted Aug 24, 2023 - 12:37 EDT