email delivery system delay

Incident Report for AgencyAnalytics

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 21:56 EST

Identified

We experienced some issues with our email provider which has caused a delay of approximately 2 hours with our email delivery system. We are expecting everything to return to normal shortly.
Posted Jan 07, 2026 - 20:34 EST
This incident affected: Report Email Notifications.