The majority of issues have been resolved and we are closely monitoring the platform
Posted Nov 14, 2024 - 16:30 EST
Update
We are continuing work on the instability issues. Overall, we are seeing improvement across the platform.
Posted Nov 14, 2024 - 13:56 EST
Identified
We just performed an update to our core infrastructure. As a result we are experiencing some minor instability in isolated areas of the app. We are working to fix these problems quickly.